Object Storage - Performance degradation

Incident Report for Exonet

Monitoring

The underlying issue preventing the healing process from completing has been resolved. The process has since finished successfully and data redundancy is fully restored. Some background maintenance activity is still running, which is expected.

We will continue to monitor the situation closely.
Posted Aug 31, 2026 - 11:00 CEST

Update

We are continuing to work on a fix for this issue.
Posted Aug 27, 2026 - 15:23 CEST

Identified

The issue has been identified and a fix is being implemented.
Posted Aug 26, 2026 - 14:10 CEST

Investigating

Our monitoring detected increased latency on a part of our storage platform. Engineers are currently investigating the issue. Customers may experience degraded performance on some services until the issue has been resolved.
Posted Aug 26, 2026 - 14:09 CEST
This incident affects: Storage (Object storage) and Build and Deployments (Container registry).