Cloudflare - Outage

Incident Report for Exonet

Resolved

Cloudflare has implemented a fix and believes the incident is now resolved. They are continuing to monitor for errors to ensure all services are back to normal.
Posted Nov 18, 2025 - 15:47 CET

Update

Cloudflare is continuing working on restoring application services.
Posted Nov 18, 2025 - 15:02 CET

Update

Cloudflare has identified the issue and a fix is being implemented.
Posted Nov 18, 2025 - 14:12 CET

Update

Cloudflare is seeing services recover, but customers may continue to observe higher-than-normal error rates as they continue remediation efforts.
Posted Nov 18, 2025 - 13:27 CET

Identified

Cloudflare experiences Global Network issues. Cloudflare is aware of, and investigating an issue which potentially impacts multiple customers.
Posted Nov 18, 2025 - 13:04 CET
This incident affected: External (Cloudflare Amsterdam, Netherlands - (AMS), Cloudflare CDN/Cache).