We are no longer experiencing delivery issues from srv02.exofilter.com to Microsoft/Outlook services. We will be moving customers back to srv02.exofilter.com this week and we will continue to monitor the situation.
Posted Apr 28, 2026 - 17:13 CEST
Update
Microsoft/Outlook (SNDS) has reported an issue that may result in certain IP addresses being temporarily rejected at higher rates. They are actively investigating the problem. We are exploring alternative solutions and working to contact Microsoft regarding the ongoing issues.
Posted Apr 23, 2026 - 11:32 CEST
Identified
We are currently experiencing outgoing mail delivery issues from srv02.exofilter.com to Microsoft/Outlook services. Our team is investigating the problem and working on a resolution. Updates will follow as more information becomes available.