We are continuing to monitor for any further issues.
Posted Jun 02, 2026 - 22:56 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 02, 2026 - 22:56 CEST
Investigating
We're seeing network issues on a limited part of our network due to a DDoS. Engineers are currently investigating the issue. Customers may experience degraded performance on some services until the issue has been resolved.