Incoming phone calls

Incident Report for Exonet

Resolved

This incident has been resolved.
Posted May 14, 2025 - 10:33 CEST

Identified

We are currently experiencing issues with incoming phone calls. Our team is investigating the cause in collaboration with our telecom provider. While we work to resolve this issue, you can reach us via email. We will call you back as soon as possible.
Posted May 14, 2025 - 09:00 CEST
This incident affected: Services (Customer Service).