Users may be unable to send email to outlook.com
Incident Report for Exonet
Resolved
It seems the issues with mail deliveries to outlook.com have been resolved at Microsoft. The incident on the Microsoft status page is not completely resolved.

For any further information about this incident check the status on the following site: https://portal.office.com/servicestatus
Posted Jul 06, 2022 - 15:02 CEST
Identified
The issue has been identified.
Posted Jul 06, 2022 - 11:37 CEST
Investigating
Customers may be unable to send email to outlook.com, for more information check the status on the following site: https://portal.office.com/servicestatus
Posted Jul 06, 2022 - 11:37 CEST
This incident affected: External (Microsoft Outlook).